0

Free Training When You’re Snowed In, What’s Not To Love

by Angela 2. January 2014 12:15

So it’s been snowing in Chicago, a LOT. I am in Oak Park, specifically, and holy moly did we ever get dumped on. Here, in case you think I’m being a big baby, this was my back deck at 7am this morning and it’s STILL snowing quite hard. There’s almost 10 inches of snow on those chairs right now, and there’s a pergola over them!

WP_20140102_07_54_12_Pro

Anyway, that’s not my point. My point is that I get to work from home this week, thank goodness, and ran across a great set of training classes on Microsoft Virtual Academy to fill some time. It’s free, yes FREE, and there are a LOT of technologies to choose from including ALM.  Although I’ll admit the ALM stuff is pretty light and scarce, and mostly focuses on 2012, so I’ll be nagging some folks about that soon. But there are also classes on Azure, HTML 5, even licensing!

Here is the current list of tools and technologies covered:

image

Clicking on Visual Studio I find a lot of great classes to get me up to speed on Windows development, HTML 5, you name it! What you see below is just the first few that came up, it’s a LONG list.

image

Best part is you can build up a nice little wish list since you may not have time to take everything today. So build a training plan, or several, and save the classes you like and take them at your own pace. Easy!  I already had one started from a while ago, but need to go back through and update it with some new classes, obviously :-P

image 

So dig in by starting here. And get some of those Microsoft certifications knocked out while you’re trapped in your house by snowmageddon.

0

Missing Some Important Icons (Admin, Help, Run Query) From Your TFS Service Web Tools?

by Angela 16. September 2013 16:00

So this was an interesting issue I ran into the other day, and all my Binging and Googling Kung-Fu produced nothing. I often run my TFS tools in multiple browsers. I mean, c’mon, I may prefer FireFox for some things, but Microsoft prefers if I use Internet Explorer when demoing to their customers ;) One day I launched into my TFS Service demo and noticed a few buttons had just vaporized off of the main web dashboard (the “agile” planning tools dashboard, not SharePoint.  Notice below how there are no buttons in the upper left-hand corner in IE, namely the Admin and Help icons:

image 

I can click where the icons SHOULD appear, and the buttons work, they just are invisible.  I thought I was crazy until a few coworkers were able to reproduce it on MY TFS Service instance, but not their own. As a former Microsoft employee I was a SUPER early adopter, so it was safe to assume we might be on different instances.

And then I verified it was fine in FireFox for that same instance:

image

WEIRD!!  I started spelunking around and noticed random icons were missing on other pages too:

image 

At this point I called in the heavy hitters, also known as the TFS Product Team, MVPs, and TFS Rangers for help.  And as usual they came to the rescue quickly. (Thanks Aaron Bjork!!)  So here was the solution in case anyone else runs into this strange issue.

There is a weird rendering bug in IE (9 and 10) with some instances of TFS Service. The way to get your buttons to re-appear is to tweak the Accelerated Graphics setting like so:

image 

Then once you restart the browser, everything should be back to normal again. Voila! :)

image

Tags:

ALM | Application Lifecycle Management | TFS 2013 | TFS Service | VS 2013 | Internet Explorer | IE 10

Powered by BlogEngine.NET 2.7.0.0
Original Design by Laptop Geek, Adapted by onesoft